5G Networks Status Page - Unplanned - Internet Service Outage – Incident details

All systems operational

Unplanned - Internet Service Outage

Resolved
Operational
Started over 4 years agoLasted about 3 hours
Updates
  • Resolved
    Resolved

    Please be advised our supplier partner has RESOLVED the network issue which was impacting your internet services. No further impact is expected. If you continue to have issues with your service, please contact our support team. Our apologies for the inconvenience this may have caused.

  • Investigating
    Investigating

    Please be advised that one of our upstream provider is experiencing issues in their network resulting in outage to internet services. We are working with the supply partner to resolve the issue. We appreciate your patience during this time and will continue to provide updates with the progress. Next update:1PM